Discussion:
Change 37517 is missing dbghll.h
(too old to reply)
Frank Beythien
2014-06-13 15:54:52 UTC
Permalink
Raw Message
Hi Steven,

your change 37517 needs your dbghll.h, I assume


====================== 13:30:18 E:\OWB\bld\wl\prebuild
wcpp -zk0 -DRC_OS2 E:\OWB\bld\sdk\rc\rc\h\rc.msg >wrcmsg.gh
awk -v rcbase=800 -f E:\OWB\bld\sdk\misc\msgtoh.awk wrcmsg.gh > rcmsg.gh
bwrc -q -bt=windows -IE:\OWB\bld\watcom\h -zk0 -r -DRC_OS2
-I"E:\OWB\bld\sdk\rc\rc\h" ..\h\wlink.rc -fo=wlink.res
cc autogrp.obj

...

cc cmdqnx.obj
cc dbgall.obj
..\c\dbgall.c(48): Error! E1055: Unable to open 'dbghll.h'
..\c\dbgall.c(77): Warning! W131: No prototype found for function 'HllInit'
...

CU/2
Frank
Steven Levine
2014-06-14 08:24:11 UTC
Permalink
Raw Message
On Fri, 13 Jun 2014 15:54:52 UTC, Frank Beythien <***@gmx.de>
wrote:

Hi Frank,
Post by Frank Beythien
your change 37517 needs your dbghll.h, I assume
Yes and dbghll.c. They were on my list to p4 add, but I managed to
forget. Gregg is helping me test and he already ran into this one, so
it is resolved.

There's a remaining problem with the prebuild wlink. I don't why I
neglected to test building the prebuild wlink, but I did.

I think that the RDOS support may have changed the build system to
build the prebuild wlink before clib. However, I need to verify this
and see what my options are.

Perhaps I can adjust the prebuild logic to work for all build
platfroms with the existing OS/2 wlink code. If not, I will tweak the
prebuild OS/2 wlink to omit high memory support unless I can come up
with a better solution.

BTW, are you doing automatic builds for every submit?

Thanks,

Steven
--
---------------------------------------------------------------------
Steven Levine <***@earthlink.bogus.net>
DIY/Warp/eCS etc. www.scoug.com
---------------------------------------------------------------------
Frank Beythien
2014-06-14 09:37:24 UTC
Permalink
Raw Message
Post by Steven Levine
Hi Frank,
Post by Frank Beythien
your change 37517 needs your dbghll.h, I assume
Yes and dbghll.c. They were on my list to p4 add, but I managed to
forget. Gregg is helping me test and he already ran into this one, so
it is resolved.
There's a remaining problem with the prebuild wlink. I don't why I
Yes, I saw it.
Post by Steven Levine
Perhaps I can adjust the prebuild logic to work for all build
platfroms with the existing OS/2 wlink code. If not, I will tweak the
prebuild OS/2 wlink to omit high memory support unless I can come up
with a better solution.
No hurry.
Post by Steven Levine
BTW, are you doing automatic builds for every submit?
Sort of. It is not automatic, but if I see new changes I run the
bldserver in eCS 2.2 beta 2 under Virtualbox. If successful I copy the
results to efbe.musca.uberspace.de.

CU/2
Frank

Loading...